Audio Signalverzerrung

  • Tests gemacht!
    Verzerrung des Audiosignals nicht auf die Relais Software abhängen.
    UP4 DAR funktioniert das gleiche mit dem Relais des Control Center als Relais für PCRepeatersoftware.
    Greg

  • Hi Greg,


    im Englischen würde man vieleicht "distorted" sagen.


    Ich finde das wirklich schade, den wenn man die Audioausgabe z.B. bei IP-Betrieb mit der Konkurenz vergleicht, dann ist das wirklich Klasse. Bei anderen setzt mit der NF ein derat hoher Rauschpegel ein, dass ich ein DAIWA-Filter dazwischen setzen musste.



    73, Holger - DL9HDA

  • Hallo zusammen,


    dem Thema, das in diesem Thread aufgekommen ist, messe ich auch eine sehr große Bedeutung bei. Es ist tatsächlich sehr ärgerlich, wenn die Nutzer unterschiedliche Selbstbaugeräte nutzen und dabei eine Beeinträchtigung beim Betrieb feststellen.


    Offensichtlich liegt hier ein technisches Problem vor, das geklärt und gelöst werden soll. Deswegen haben Torsten DG1HT und ich uns bereits zu diesem Thema kurzgeschlossen und werden dieses Problem näher anschauen.


    Dabei werden die Fakten gesammelt, die Probleme identifiziert und erst daraus mögliche Lösungsvorschläge erarbeitet.


    Deshalb möchte ich euch alle um Geduld bitten und sich bis dahin nicht mehr zu dem Thema zu äußern.


    Denn die Gefahr ist durchaus gegeben, daß man durch zum Teil nicht ganz richtige Messungen, oder nicht richtige Interpretationen der Beobachtungen falsche Schlüsse zieht und dadurch gar einen unsachlichen „Glaubenskrieg“ auslösen könnte.


    Sobald die entsprechenden Untersuchungen und Beratungen abgeschlossen sind, wird hier im Forum das Ergebnis kommuniziert und allen Nutzer die Möglichkeit geben, Fragen zu stellen und mit zu diskutieren.


    Danke für euer Verständnis und Geduld!


    73 de Denis DL3OCK

  • Hallo zusammen,


    da es seit meinem letzten Beitrag in diesem Thread schon eine Weile her ist, wollte ich mich mit einem Zwischenergebnis melden. Die restlichen Untersuchungen stehen aus den Gründen, die ich gleich aufführe noch aus.


    Vor einigen Wochen habe ich leihweise einen DVRPTR V3 Board bekommen. Diesen Board haben wir in Betreib genommen und uns das digital modulierte analoge Ausgangssignal an dem Pin1 der PS2-Buchse angeschaut. Das Ergebnis ist eigentlich wie erwartet ausgefallen und hat NUR die bereits bekannten Probleme an den Tag geliefert, nämlich:

    • Die Baudrate ist um ca. 345ppm zu schnell als die spezifizierten 4800Baud
    • Das s.g. TerminationFlag wird an der falschen Position gesendet.

    Nun wozu führen die beiden Probleme.
    Die zu schnelle Ausgabe von den digitalen Symbolen führt zum Bufferüberlauf an einem Empfänger nach ca. 60sec. Das Aussenden von TerminationFlag an der umspezifizierten Stelle führt i.a.R. zum Nachklotzeln am Ende eines Durchgangs. In dem Verlauf eines von DVRPTR V3 ausgestrahlten Signals fanden wir keine Indiz, warum es zu fortlaufenden Störung der Sprachdaten kommen sollte.
    Als wir den Ausgang von DVRPTR V3 an ein UP4DAR direkt oder über eine HF-Strecke (also ein UKW-FM-Sender an DVRPTR V3 und ein UKW-FM-Empfänger an UP4DAR) angeschlossen haben, haben unsere vorigen Beobachtungen und Vermutungen bestätigt. Es treten keine Störungen im Sprachsignal auf!


    Daher hatten wir vermutet, daß eine fortlaufende Beeinträchtigung des Ausgangssignal nur dann auftritt, wenn auf die DVRPTR V3 Platine weitere Boards aufgesteckt werden (z.B. AMBE-Board oder LAN-Modul). Da wir selber noch über keinen Erweiterungsmodul verfügen, hat ein bekannter OM für uns diesen Test
    durchgeführt und tatsächlich bestätigt, daß ein "nackter" DVRPTR V3 Board ein sauberes Signal liefert und erst beim Einstecken eines AMBE-Zusatzmoduls
    fortlaufende Probleme in den Sprachdaten auftauchen!


    Das ist im Moment unser Zwischenergebnis!


    Das bedeutet, daß wahrscheinlich auch alle DVRPTR V2 Boards (nicht "light"), bei denen AMBE-Chip und/oder LAN-Chip fest aufgelötet ist, auch ein problematisches Signal haben dürften.


    Sobald wir ein AMBE-Modul haben und die Messungen im Labor damit machen können, kann ich genau sagen, was genau im Signal problematisch wird und ob eine geeignete Gegenmaßnahme am Empfänger auf eine wirtschaftliche Weise realisiert werden kann.



    73 de Denis DL3OCK

  • Quote

    Das
    bedeutet, daß wahrscheinlich auch alle DVRPTR V2 Boards (nicht
    "light"), bei denen AMBE-Chip fest aufgelötet ist, auch ein
    problematisches Signal haben dürften.

    Moin Dennis, dass kann ich so nicht bestätigen. Ich habe einen Repeater mit V2 Light und einen mit V3 aufgebaut. Beide verfügen über keinen AMBE-Chip. Beide haben zwar einen Netzwerkanschluss, dieser wird jedoch nicht genutzt.


    Bei beiden lässt sich die Aussendung mit IC-E91, ID-E880 und Kombination aus z.B. FT7900+DVRPTR-V3 (inc. AMBE) oder IC-820H+DVRPTR-V3 (inc. AMBE) einwandfrei dekodieren. Nicht jedoch mit UP4DAR.


    Holger

  • Hallo Holger,


    in dem von Dir zitierten Satz habe ich mich etwas unglücklich (im Sinne der obigen Erklärung) ausgedrückt. Den Satz habe ich gerade korrigiert. Es sollte richtig heißen, daß eine "nackte" DVRPTR-Platine ein unproblematisches Signal hat. Sobald aber ein Erweiterungsmodul aufgesteckt oder eingelötet wird (und das sind eben entweder AMBER oder LAN, und unabhängig davon, ob sie verwendet werden), wird das Ausgangssignal problematisch!


    Was genau an dem Signal nicht stimmt, kann ich erst sagen, wenn wir über einen Aufsteckmodul verfügen und es durchgemessen und analysiert haben.


    73 de Denis OE/DL3OCK

  • Hallo Denis!


    Ich konnte das Verhalten jetzt auch mit einem V1-Board nachstellen.
    Tatsächlich stimmt mit und ohne aufgesetztem AMBE-Board lt. Anzeige vom UP4DAR die Baud-Rate des vom DVRPTR erzeugten Sendesignals nicht (-430). Die Effekte sind wie in diesem Thread beschrieben und ich dachte bisher an ein Problem im Bereich des Diskriminators des Empfängers, da eine Decodierung durch das UP4DAR mit der neueren Firmware so gut wie unmöglich war.
    Du hattest mein Board ja mal zu checken und es war nichts auffällig ;-)


    Der Versuch den Quarz im V1-Board zu ziehen war nur bedingt erfolgreich - bis ca. -200 ist möglich - mehr jedoch nicht.


    Ein Gegentest mit der neuen ICOM-Gerätegeneration ID-5100 und dem ID-51 bringt mit dem V1 Board jetzt auch deutlich schlechtere Empfangsergebnisse, wenn das DVRPTR-Board als Sender (wie bei uns am Relais) verwendet wird. Die älteren Geräte wie z.B. das 2820 waren hier offener gegenüber nicht ganz normkonformen Signalen. Es ist auch zu beobachten, dass "normkonforme" Signale (z.B. ICOM-Repeater) im Mobilbetrieb mit den neuen ICOM-Geräten wesentlich besser/zuverlässiger demoduliert werden.


    Schön wäre, wenn das DVRPTR-Board ein Update der Firmware bekommen würde (es ist doch sehr verbreitet) und auch das UP4DAR etwas "toleranter" wäre ;-)


    vy 73
    Franz

  • Hallo Franz,


    es ist schön, daß Du durch praktische Experimente unsere Ausführungen bestätigst.

    Schön wäre, wenn das DVRPTR-Board ein Update der Firmware bekommen würde (es ist doch sehr verbreitet) und auch das UP4DAR etwas "toleranter" wäre ;-)

    An dieser Stelle möchte ich noch mal wiederholen, daß ich nicht möchte UP4DAR-Empfangsalgorithmen wieder unempfindlicher zu machen, indem ich die Errungenschaften der letzten PHY-Versionen wieder ausbaue. Also den Empfangsalgorithmus unempfindlicher machen und dafür mehr verzeihlich gegenüber einem problematischen DVRPTR-Signal werden.
    Was ich mir durchaus überlegen kann, wäre eine Sonderbehandlung eines DVRPTR-Problemsignals, sofern dieses erkannt worden ist. Dafür muß ich aber das Problem an meinem Schreibtisch wenigstens einmal gesehen haben, um zu verstehen, was genau das Problem bei der Signalerzeugung eines DVRPTR-Board ist, wenn dort ein Erweiterungsmodul aufgesteckt bzw. aufgelötet ist!
    Ich habe immer noch eine Leihgabe von einem OM, ein DVRPTR V3 Hauptboard, aber ohne ein Zusatzmodul. D.h. mir fehlt ein Aufsteckmodul (AMBE oder ETH), um das Problem hier zu simulieren.
    Wenn jemand uns für eine kurze Zeit sein Zusatzmodul zur Verfügung stellt, kommen wir vielleicht in dieser Sache weiter.


    73 de Denis OE/DL3OCK

  • Servus zusammen,


    wollte nur kurz anmerken, dass ich ebenfalls in der Lage bin das hier geschilderte Problem nachzustellen.
    Bei dem DSTAR Repeater DB0THM B hab ich leider auch die Audio Verzerrungen.
    Leider weiß ich jetzt nicht welche Hardware dort im Einsatz ist :(


    Mit dem ID-51 klappt der Empfang jedoch problemlos.


    Ist für mich jetzt auch nicht so wichtig da ich andere Repeater erreiche bei denen keine Probleme auftauchen und ich die UP4DAR Platine eigentlich meistens im HotSpot Modus betreibe ...


    Gruß aus Bayern,
    DO3MBJ (Jürgen)